{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-5089 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-5089 is a high-severity memory corruption vulnerability in TODDR YAML::Syck, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-5089 and fix it if it is affected.\n\nWhat it is: CVE-2026-5089 is a high-severity memory corruption vulnerability in TODDR YAML::Syck, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-5089 exists.\n\nAffected product: TODDR YAML::Syck. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-5089/ (Markdown: https://insights.sbomify.com/CVE-2026-5089/index.md)","id":"CVE-2026-5089","markdown":"https://insights.sbomify.com/CVE-2026-5089/index.md","name":"CVE-2026-5089","record":{"aliases":["AZL-109511","AZL-86901","BELL-CVE-2026-5089","DEBIAN-CVE-2026-5089","GHSA-jcwf-qrr5-xwq3","MGASA-2026-0148","UBUNTU-CVE-2026-5089","openSUSE-SU-2026:10846-1","openSUSE-SU-2026:20938-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl YAML library","requires_auth":"none","summary":"An out-of-bounds read in YAML::Syck allows attackers to cause denial of service or disclose memory contents via crafted YAML input.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CPANSec","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-124","name":"Buffer Underwrite"}],"description":"YAML::Syck versions before 1.38 for Perl  has an out-of-bounds read.\n\nThe base60 (sexagesimal) parsing code in perl_syck.h has a buffer underflow bug in both int#base60 and float#base60 handlers. When processing the leftmost segment of a colon-separated value (e.g., the 1 in 1:30:45), the inner while loop can decrement a pointer past the start of the string buffer:\n\n    while ( colon \u003e= ptr \u0026\u0026 *colon != ':' )\n    {\n        colon--;\n    }\n    if ( *colon == ':' ) *colon = '\\0';  // colon may be ptr-1 here\n\nWhen no colon is found (final/leftmost segment), colon becomes ptr-1, and the subsequent *colon dereference reads one byte before the allocated buffer.","ecosystems":["openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"YAML::Syck versions before 1.38 for Perl has an out-of-bounds read","id":"CVE-2026-5089","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Template::Plugin::HTML versions before 3.103 for Perl allows HTML and JavaScript to be injected","id":"CVE-2026-5090"},"packages":[{"ecosystem":"openSUSE:Leap 16.0","fixed":["1.450.0-bp160.2.1"],"introduced":["0"],"last_affected":[],"package":"perl-YAML-Syck","purl":"pkg:rpm/opensuse/perl-YAML-Syck\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:20938-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.450.0-4.1"],"introduced":["0"],"last_affected":[],"package":"perl-YAML-Syck","purl":"pkg:rpm/opensuse/perl-YAML-Syck\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10846-1"}],"prev":{"headline":"Apache::API::Password versions through 0.5.2 for Perl can generate insecure random values for salts","id":"CVE-2026-5088"},"products":["YAML::Syck"],"published":"2026-05-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-14","vendors":["TODDR"]},"summary":"An out-of-bounds read in YAML::Syck allows attackers to cause denial of service or disclose memory contents via crafted YAML input.","url":"https://insights.sbomify.com/CVE-2026-5089/"}