{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-5107 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2026-5107 is a low-severity missing authorization vulnerability in FRRouting FRR, published on 30 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-5107 and fix it if it is affected.\n\nWhat it is: CVE-2026-5107 is a low-severity missing authorization vulnerability in FRRouting FRR, published on 30 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-5107 in the wild and no public exploit code.\n\nAffected product: FRRouting FRR. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-5107/ (Markdown: https://insights.sbomify.com/CVE-2026-5107/index.md)","id":"CVE-2026-5107","markdown":"https://insights.sbomify.com/CVE-2026-5107/index.md","name":"CVE-2026-5107","record":{"aliases":["AZL-81087","DEBIAN-CVE-2026-5107","GHSA-27p7-fq6v-hh4m","UBUNTU-CVE-2026-5107","openSUSE-SU-2026:10606-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"FRRouting network routing","requires_auth":"low_privilege","summary":"Remote attackers can bypass access controls in the EVPN Type-2 Route handler, requiring high complexity and difficult exploitation.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"frrouting","vendor":"frrouting"}],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"},{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"A vulnerability has been found in FRRouting FRR up to 10.5.1. This affects the function process_type2_route of the file bgpd/bgp_evpn.c of the component EVPN Type-2 Route Handler. The manipulation leads to improper access controls. The attack can be initiated remotely. The attack is considered to have high complexity. The exploitability is reported as difficult. The identifier of the patch is 7676cad65114aa23adde583d91d9d29e2debd045. To fix this issue, it is recommended to deploy a patch.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"FRRouting FRR EVPN Type-2 Route bgp_evpn.c process_type2_route access control","id":"CVE-2026-5107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":1,"n_references":6,"next":{"headline":"Cross-site scripting in Super Progressive Web Apps","id":"CVE-2026-5108"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["10.5.1-3.1"],"introduced":["0"],"last_affected":[],"package":"frr","purl":"pkg:rpm/opensuse/frr\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10606-1"}],"prev":{"headline":"code-projects Exam Form Submission update_fst.php cross site scripting","id":"CVE-2026-5106"},"products":["FRR"],"published":"2026-03-30","related":[{"cvss_score":9.8,"headline":"Denial of service in n/a","id":"CVE-2024-44070","kev_date_added":null,"published":"2024-08-19"},{"cvss_score":9.8,"headline":"bgpd/bgp_flowspec.c in FRRouting (FRR) before 8.4.3 mishandles an nlri length of zero, aka a \"flowspec overflow.\"","id":"CVE-2023-38406","kev_date_added":null,"published":"2023-11-06"},{"cvss_score":8.1,"headline":"Use after free in n/a","id":"CVE-2022-37035","kev_date_added":null,"published":"2022-08-02"},{"cvss_score":7.8,"headline":"Memory corruption in FRRouting","id":"CVE-2022-26127","kev_date_added":null,"published":"2022-03-03"},{"cvss_score":7.8,"headline":"Memory corruption in FRRouting","id":"CVE-2022-26128","kev_date_added":null,"published":"2022-03-03"},{"cvss_score":7.8,"headline":"Memory corruption in FRRouting","id":"CVE-2022-26129","kev_date_added":null,"published":"2022-03-03"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2026-37457","kev_date_added":null,"published":"2026-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-30","vendors":["FRRouting"]},"summary":"Remote attackers can bypass access controls in the EVPN Type-2 Route handler, requiring high complexity and difficult exploitation.","url":"https://insights.sbomify.com/CVE-2026-5107/"}