{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-5130 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-5130 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-5130 is a high-severity authentication bypass vulnerability in jhimross Debugger \u0026 Troubleshooter, published on 30 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-5130 and fix it if it is affected.\n\nWhat it is: CVE-2026-5130 is a high-severity authentication bypass vulnerability in jhimross Debugger \u0026 Troubleshooter, published on 30 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-5130 in the wild and no public exploit code.\n\nAffected product: jhimross Debugger \u0026 Troubleshooter. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-5130/ (Markdown: https://insights.sbomify.com/CVE-2026-5130/index.md)","id":"CVE-2026-5130","markdown":"https://insights.sbomify.com/CVE-2026-5130/index.md","name":"CVE-2026-5130","record":{"aliases":["GHSA-24w3-v7fc-cjwv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Unauthenticated attackers can gain administrator access by manipulating a cookie, allowing full site control and privilege escalation.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-565","name":"Reliance on Cookies without Validation and Integrity Checking"}],"description":"The Debugger \u0026 Troubleshooter plugin for WordPress was vulnerable to Unauthenticated Privilege Escalation in versions up to and including 1.3.2. This was due to the plugin accepting the wp_debug_troubleshoot_simulate_user cookie value directly as a user ID without any cryptographic validation or authorization checks. The cookie value was used to override the determine_current_user filter, which allowed unauthenticated attackers to impersonate any user by simply setting the cookie to their target user ID. This made it possible for unauthenticated attackers to gain administrator-level access and perform any privileged actions including creating new administrator accounts, modifying site content, installing plugins, or taking complete control of the WordPress site. The vulnerability was fixed in version 1.4.0 by implementing a cryptographic token-based validation system where only administrators can initiate user simulation, and the cookie contains a random 64-character token that must be validated against database-stored mappings rather than accepting arbitrary user IDs.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Debugger \u0026 Troubleshooter \u003c= 1.3.2 - Unauthenticated Privilege Escalation to Administrator via Cookie Manipulation","id":"CVE-2026-5130","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Server-Side Request Forgery in GREENmod","id":"CVE-2026-5131"},"packages":[],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2026-5128"},"products":["Debugger \u0026 Troubleshooter"],"published":"2026-03-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["jhimross"]},"summary":"Unauthenticated attackers can gain administrator access by manipulating a cookie, allowing full site control and privilege escalation.","url":"https://insights.sbomify.com/CVE-2026-5130/"}