CVE-2026-5139 GitLab Plugin Allows Non-Admin Users to Modify Default Instance Configuration

Medium 5.4 Published Updated

Authenticated users can modify global GitLab instance configuration due to missing admin authorization checks in the Mattermost plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-5139?

CVE-2026-5139 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 11.7.x <= 11.7.0, 11.6.x <= 11.6.2, 11.5.x <= 11.5.5, 10.11.x <= 10.11.17 fail to enforce administrator authorization on the {{setDefaultInstance}} call within the {{/gitlab connect}} command handler, which allows any authenticated user to overwrite the global default GitLab instance configuration via the {{/gitlab connect <instance-name>}} slash command.. Mattermost Advisory ID: MMSA-2026-00644

Weakness: CWE-862

Which versions are affected by CVE-2026-5139?

9 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoFrom 10.11.010.11.18
github.com/mattermost/mattermost-server GoFrom 10.11.010.11.18
github.com/mattermost/mattermost-server GoFrom 10.11.0+incompatible10.11.18+incompatible, 11.5.6+incompatible, 11.6.3+incompatible, 11.7.1+incompatible
github.com/mattermost/mattermost-server GoFrom 11.5.011.5.6
github.com/mattermost/mattermost-server GoFrom 11.5.011.5.6
github.com/mattermost/mattermost-server GoFrom 11.6.011.6.3
3 more packages
github.com/mattermost/mattermost-server GoFrom 11.6.011.6.3
github.com/mattermost/mattermost-server GoFrom 11.7.011.7.1
github.com/mattermost/mattermost-server GoFrom 11.7.011.7.1

Products include Mattermost Mattermost Server.

How do I fix CVE-2026-5139?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.18, 10.11.18+incompatible, 11.5.6+incompatible or 11.6.3+incompatible.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-5139 being exploited?

There is no known exploitation of CVE-2026-5139 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-2g8v-grq3-hq2g, GO-2026-6480.

Is CVE-2026-5139 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free