# CVE-2026-5139: GitLab Plugin Allows Non-Admin Users to Modify Default Instance Configuration

> Authenticated users can modify global GitLab instance configuration due to missing admin authorization checks in the Mattermost plugin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-2g8v-grq3-hq2g, GO-2026-6480

## What is CVE-2026-5139?

CVE-2026-5139 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.7.x <= 11.7.0, 11.6.x <= 11.6.2, 11.5.x <= 11.5.5, 10.11.x <= 10.11.17 fail to enforce administrator authorization on the {{setDefaultInstance}} call within the {{/gitlab connect}} command handler, which allows any authenticated user to overwrite the global default GitLab instance configuration via the {{/gitlab connect <instance-name>}} slash command.. Mattermost Advisory ID: MMSA-2026-00644

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-5139?

9 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.18 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.18 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | 10.11.18+incompatible, 11.5.6+incompatible, 11.6.3+incompatible, 11.7.1+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.6 |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.6 |
| `github.com/mattermost/mattermost-server` | Go | From 11.6.0 | 11.6.3 |
| `github.com/mattermost/mattermost-server` | Go | From 11.6.0 | 11.6.3 |
| `github.com/mattermost/mattermost-server` | Go | From 11.7.0 | 11.7.1 |
| `github.com/mattermost/mattermost-server` | Go | From 11.7.0 | 11.7.1 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-5139?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.18, 10.11.18+incompatible, 11.5.6+incompatible or 11.6.3+incompatible.

## Is CVE-2026-5139 being exploited?

There is no known exploitation of CVE-2026-5139 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5139 and fix it if it is affected.

What it is: CVE-2026-5139 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-5139 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.18
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.18
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; fixed in 10.11.18+incompatible, 11.5.6+incompatible, 11.6.3+incompatible, 11.7.1+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.6
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.6
- github.com/mattermost/mattermost-server (Go): affected from 11.6.0; fixed in 11.6.3
- github.com/mattermost/mattermost-server (Go): affected from 11.6.0; fixed in 11.6.3
- github.com/mattermost/mattermost-server (Go): affected from 11.7.0; fixed in 11.7.1
- github.com/mattermost/mattermost-server (Go): affected from 11.7.0; fixed in 11.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5139/ (Markdown: https://insights.sbomify.com/CVE-2026-5139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5139
- OSV: https://osv.dev/vulnerability/CVE-2026-5139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5139/
Summaries are generated and may contain mistakes; the official description above is the record.
