CVE-2026-5163 Missing authorization check in AI message rewrite endpoint allows access to private thread content
An authenticated attacker can read private thread content in Mattermost by bypassing channel membership checks on the AI message rewrite endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-5163?
CVE-2026-5163 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.5.x <= 11.5.1 fail to verify channel membership when processing AI-assisted message rewrites which allows an authenticated attacker to read the content of threads in private channels and direct messages they do not have access to via a crafted request to the post rewrite endpoint.. Mattermost Advisory ID: MMSA-2026-00645
Weakness: CWE-862
Which versions are affected by CVE-2026-5163?
10 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260401090745-f4d1abe7e8f5 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260401090745-f4d1abe7e8f5 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260401090745-f4d1abe7e8f5 |
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0 | 11.5.2 |
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0 | 11.5.2 |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260401090745-f4d1abe7e8f5 |
4 more packages
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260401090745-f4d1abe7e8f5 |
github.com/mattermost/mattermost-server Go | From 11.5.0+incompatible | 11.5.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-5163?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20260401090745-f4d1abe7e8f5 or 11.5.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-5163 being exploited?
There is no known exploitation of CVE-2026-5163 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-8r89-8w26-cq32, GO-2026-5263.