CVE-2026-51886 Langflow: Title Authenticated Remote Code Execution in validate_code via Malicious Decorators Description
An authenticated attacker can execute arbitrary Python code on the server by submitting malicious input to the code validation endpoint.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-51886?
CVE-2026-51886 is a critical code injection vulnerability in n/a, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
langflow-ai langflow v1.9.3 is affected by: Code Injection. The impact is: execute arbitrary code (remote). The component is: src/backend/base/langflow/api/v1/validate.py:validate-post_validate_code-a-real-authenticated-http-post-to-api-v1. The attack vector is: Attack surface: HTTP or browser-backed service path. A public-facing route accepts raw Python source and forwards it into a server-side compile/exec validation path without any visible entitlement guard. ¶¶ A weakness has been identified in langflow-ai langflow up to 1.9.3. langflow contains a code injection vulnerability in validate-post_validate_code-a-real-authenticated-http-post-to-api-v1 (src/backend/base/langflow/api/v1/validate.py:13). An authenticated attacker can execute arbitrary Python code on the server by submitting malicious code to the /api/v1/validate/code endpoint, which directly executes user-supplied code without sandboxing or security controls.
Weakness: CWE-94
Which versions are affected by CVE-2026-51886?
3 open source packages ship an affected version, including langflow.
| Package | Affected | Fixed in |
|---|---|---|
langflow PyPI | From 1.7.2 | 1.10.1 |
langflow PyPI | From 1.7.2 | 1.10.1 |
langflow PyPI | From 1.7.2 | 1.10.1 |
How do I fix CVE-2026-51886?
Upgrade langflow to 1.10.1 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-51886 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-51886 exists.
Sources
Also known as GHSA-w584-2h2r-2hvf, PYSEC-2026-4236.