{"answers":{"affected":"3 open source packages ship an affected version, including langflow.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-51886 exists.","fix":"Upgrade langflow to 1.10.1 or later.","what":"CVE-2026-51886 is a critical code injection vulnerability in n/a, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-51886 and fix it if it is affected.\n\nWhat it is: CVE-2026-51886 is a critical code injection vulnerability in n/a, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-51886 exists.\n\nAffected packages and fixed versions:\n- langflow (PyPI): affected from 1.7.2; fixed in 1.10.1\n- langflow (PyPI): affected from 1.7.2; fixed in 1.10.1\n- langflow (PyPI): affected from 1.7.2; fixed in 1.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-51886/ (Markdown: https://insights.sbomify.com/CVE-2026-51886/index.md)","id":"CVE-2026-51886","markdown":"https://insights.sbomify.com/CVE-2026-51886/index.md","name":"CVE-2026-51886","record":{"aliases":["GHSA-w584-2h2r-2hvf","PYSEC-2026-4236"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Langflow AI platform","requires_auth":"none","summary":"An authenticated attacker can execute arbitrary Python code on the server by submitting malicious input to the code validation endpoint.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"langflow-ai langflow v1.9.3 is affected by: Code Injection. The impact is: execute arbitrary code (remote). The component is: src/backend/base/langflow/api/v1/validate.py:validate-post_validate_code-a-real-authenticated-http-post-to-api-v1. The attack vector is: Attack surface: HTTP or browser-backed service path. A public-facing route accepts raw Python source and forwards it into a server-side compile/exec validation path without any visible entitlement guard. ¶¶ A weakness has been identified in langflow-ai langflow up to 1.9.3. langflow contains a code injection vulnerability in validate-post_validate_code-a-real-authenticated-http-post-to-api-v1 (src/backend/base/langflow/api/v1/validate.py:13). An authenticated attacker can execute arbitrary Python code on the server by submitting malicious code to the /api/v1/validate/code endpoint, which directly executes user-supplied code without sandboxing or security controls.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Langflow: Title Authenticated Remote Code Execution in validate_code via Malicious Decorators Description","id":"CVE-2026-51886","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Path traversal in n/a","id":"CVE-2026-51888"},"packages":[{"ecosystem":"PyPI","fixed":["1.10.1"],"introduced":["1.7.2"],"last_affected":[],"package":"langflow","purl":null,"source":"GHSA-w584-2h2r-2hvf"},{"ecosystem":"PyPI","fixed":["1.10.1"],"introduced":["1.7.2"],"last_affected":[],"package":"langflow","purl":"pkg:pypi/langflow","source":"GHSA-w584-2h2r-2hvf"},{"ecosystem":"PyPI","fixed":["1.10.1"],"introduced":["1.7.2"],"last_affected":[],"package":"langflow","purl":"pkg:pypi/langflow","source":"PYSEC-2026-4236"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2026-51884"},"products":["n/a"],"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-05","vendors":["n/a"]},"summary":"An authenticated attacker can execute arbitrary Python code on the server by submitting malicious input to the code validation endpoint.","url":"https://insights.sbomify.com/CVE-2026-51886/"}