# CVE-2026-5190: AWS C Event Stream Streaming Decoder Stack Buffer Overflow

> A stack buffer overflow in the AWS C event stream decoder allows remote attackers to execute arbitrary code on client applications processing crafted messages.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-xvjw-fjq5-68hf, openSUSE-SU-2026:10512-1, openSUSE-SU-2026:20477-1

## What is CVE-2026-5190?

CVE-2026-5190 is a high-severity memory corruption vulnerability in aws-c-event-stream, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Out-of-bounds write in the streaming decoder component in aws-c-event-stream before 0.6.0 might allow a third party operating a server to cause memory corruption leading to arbitrary code execution on a client application that processes crafted event-stream messages.

To remediate this issue, users should upgrade to version 0.6.0 or later.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2026-5190?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aws-c-event-stream` | openSUSE:Leap 16.0 | All versions | 0.4.2-bp160.2.1 |
| `aws-c-event-stream` | openSUSE:Tumbleweed | All versions | 0.7.0-1.1 |

## How do I fix CVE-2026-5190?

Upgrade to a fixed version.

## Is CVE-2026-5190 being exploited?

There is no known exploitation of CVE-2026-5190 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5190 and fix it if it is affected.

What it is: CVE-2026-5190 is a high-severity memory corruption vulnerability in aws-c-event-stream, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-5190 in the wild and no public exploit code.

Affected product: aws-c-event-stream. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5190/ (Markdown: https://insights.sbomify.com/CVE-2026-5190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5190
- OSV: https://osv.dev/vulnerability/CVE-2026-5190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5190/
Summaries are generated and may contain mistakes; the official description above is the record.
