# CVE-2026-5241: Policy Bypass in LightGlue Nested Config Resolution in huggingface/transformers

> Attackers can execute arbitrary code via malicious model configs, bypassing trust_remote_code protections in the Hugging Face Transformers library.

- **Severity:** High 8.0 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jun 2026
- **Updated:** 1 Sep 2026
- **Also known as:** CLSA-2026-1783991041, ECHO-2ac7-0ae4-9836, GHSA-fgcw-684q-jj6r, PYSEC-2026-2290

## What is CVE-2026-5241?

CVE-2026-5241 is a high-severity code injection vulnerability in huggingface/transformers, published on 3 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability in the LightGlue model loading path of huggingface/transformers version 5.2.0 allows an attacker-controlled model repository to execute arbitrary code during model initialization. The issue arises because the `trust_remote_code` parameter, intended to prevent remote code execution, is overridden by untrusted serialized configuration data in a nested code path. Specifically, when loading a LightGlue model using `AutoModel.from_pretrained()` with `trust_remote_code=False`, the `LightGlueConfig` reads the `trust_remote_code` value from the untrusted `config.json` file and propagates it into nested `AutoConfig.from_pretrained()` calls. This results in the execution of attacker-provided Python modules, even when the victim explicitly disables remote code execution. The vulnerability poses a high risk for environments such as API inference servers, research notebooks, CI/CD pipelines, and model evaluation workers, potentially leading to credential theft, lateral movement, or persistence/backdoor deployment.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-5241?

3 open source packages ship an affected version, including transformers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transformers` | PyPI | All versions to 5.2.0 | None |
| `transformers` | PyPI | All versions | 5.5.0 |
| `transformers` | PyPI | All versions | 5.5.0 |

Products: Huggingface Transformers.

## How do I fix CVE-2026-5241?

Upgrade transformers to 5.5.0 or later.

## Is CVE-2026-5241 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-5241 exists.

## Other vulnerabilities in huggingface/transformers

- [CVE-2023-7018](https://insights.sbomify.com/CVE-2023-7018/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.6)
- [CVE-2023-6730](https://insights.sbomify.com/CVE-2023-6730/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.0)
- [CVE-2024-11393](https://insights.sbomify.com/CVE-2024-11393/): Hugging Face Transformers MaskFormer Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2024-11394](https://insights.sbomify.com/CVE-2024-11394/): Hugging Face Transformers Trax Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2026-4372](https://insights.sbomify.com/CVE-2026-4372/): Arbitrary Remote Code Execution via `_attn_implementation_internal` Config Injection in huggingface/transformers (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5241 and fix it if it is affected.

What it is: CVE-2026-5241 is a high-severity code injection vulnerability in huggingface/transformers, published on 3 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-5241 exists.

Affected packages and fixed versions:
- transformers (PyPI): affected all versions up to 5.2.0; no fix listed
- transformers (PyPI): affected all versions; fixed in 5.5.0
- transformers (PyPI): affected all versions; fixed in 5.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5241/ (Markdown: https://insights.sbomify.com/CVE-2026-5241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5241
- OSV: https://osv.dev/vulnerability/CVE-2026-5241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5241/
Summaries are generated and may contain mistakes; the official description above is the record.
