# CVE-2026-5244: Cesanta Mongoose TLS 1.3 mongoose.c mg_tls_recv_cert heap-based overflow


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 2 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-5244, GHSA-7vfw-f3r2-9m2j, JLSEC-2026-369, UBUNTU-CVE-2026-5244

## What is CVE-2026-5244?

CVE-2026-5244 is a medium-severity vulnerability in Cesanta Mongoose, published on 2 Apr 2026. 

### Official description

A vulnerability has been found in Cesanta Mongoose up to 7.20. This affects the function mg_tls_recv_cert of the file mongoose.c of the component TLS 1.3 Handler. Such manipulation of the argument pubkey leads to heap-based buffer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.21 mitigates this issue. The name of the patch is 0d882f1b43ff2308b7486a56a9d60cd6dba8a3f1. It is advisable to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-122 (Heap-based Buffer Overflow), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-5244?

It affects 1 product.


Products: Cesanta Mongoose.

## How do I fix CVE-2026-5244?

Upgrade to a fixed version.

## Is CVE-2026-5244 being exploited?

There is no known exploitation of CVE-2026-5244 in the wild and no public exploit code.

## Other vulnerabilities in Cesanta Mongoose

- [CVE-2022-25299](https://insights.sbomify.com/CVE-2022-25299/): Arbitrary File Write (critical 9.8)
- [CVE-2020-25756](https://insights.sbomify.com/CVE-2020-25756/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-19307](https://insights.sbomify.com/CVE-2019-19307/): Integer overflow in n/a (critical 9.8)
- [CVE-2019-12951](https://insights.sbomify.com/CVE-2019-12951/): Memory corruption in n/a (critical 9.8)
- [CVE-2018-20353](https://insights.sbomify.com/CVE-2018-20353/): Use after free in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5244 and fix it if it is affected.

What it is: CVE-2026-5244 is a medium-severity vulnerability in Cesanta Mongoose, published on 2 Apr 2026. 
Exploitation: There is no known exploitation of CVE-2026-5244 in the wild and no public exploit code.

Affected product: Cesanta Mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5244/ (Markdown: https://insights.sbomify.com/CVE-2026-5244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5244
- OSV: https://osv.dev/vulnerability/CVE-2026-5244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5244/
Summaries are generated and may contain mistakes; the official description above is the record.
