# CVE-2026-52724: kuma-dp connects to control plane without verifying TLS certificate when no CA is configured

> Attackers can intercept dataplane tokens and inject malicious configurations in Kuma Universal mode when TLS verification is disabled by missing CA settings.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026

## What is CVE-2026-52724?

CVE-2026-52724 is a medium-severity vulnerability in kumahq kuma, published on 15 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Kuma is a modern Envoy-based service mesh that can run on every cloud across both Kubernetes and VMs. Prior to 2.7.26, 2.9.16, 2.11.14, 2.12.11, and 2.13.7, Universal mode kuma-dp connections to an HTTPS control plane disable TLS peer verification when --ca-cert-file is not supplied and KUMA_CONTROL_PLANE_CA_CERT is unset. The dataplane authentication token is sent over the unverified connection, allowing an on-path attacker to intercept the token, impersonate the control plane, inject a forged bootstrap configuration, and take over the proxy. Standard Kubernetes installations created by kumactl install control-plane or the official Helm chart are unaffected because the mutating admission webhook injects KUMA_CONTROL_PLANE_CA_CERT into each sidecar. This issue is fixed in versions 2.7.26, 2.9.16, 2.11.14, 2.12.11, and 2.13.7.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-52724?


## How do I fix CVE-2026-52724?

Upgrade to a fixed version.

## Is CVE-2026-52724 being exploited?

There is no known exploitation of CVE-2026-52724 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52724 and fix it if it is affected.

What it is: CVE-2026-52724 is a medium-severity vulnerability in kumahq kuma, published on 15 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-52724 in the wild and no public exploit code.

Affected product: kumahq kuma. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52724/ (Markdown: https://insights.sbomify.com/CVE-2026-52724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52724
- OSV: https://osv.dev/vulnerability/CVE-2026-52724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52724/
Summaries are generated and may contain mistakes; the official description above is the record.
