# CVE-2026-52725: Angular Template and Dynamic Component Namespace Bypass leading to Cross-Site Scripting (XSS)

> Attackers can inject scripts by mounting Angular components onto script tags, leading to client-side code execution.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** CLSA-2026-1792931815, DEBIAN-CVE-2026-52725, GHSA-692r-grfm-v8x7, UBUNTU-CVE-2026-52725

## What is CVE-2026-52725?

CVE-2026-52725 is a medium-severity cross-site scripting vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, an issue in the @angular/core package allows bypassing script-execution restrictions during dynamic component creation. Specifically, the dynamic component instantiation mechanism (createComponent) failed to reject mounting components directly onto a <script> or namespaced script element (such as <svg:script>). This enabled the initialization of custom components on a tag that executes scripts, allowing attackers to hijack or inject script-executing hosts. This flaw enables an attacker who can control the host element or selector parameter passed to createComponent to initialize or mount an Angular component directly onto a <script> tag, leading to execution of untrusted code or client-side Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-52725?

10 open source packages ship an affected version, including @angular/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/core` | npm | All versions to 18.2.14 | None |
| `@angular/core` | npm | All versions to 18.2.14 | None |
| `@angular/core` | npm | From 19.0.0-next.0 | 19.2.23 |
| `@angular/core` | npm | From 19.0.0-next.0 | 19.2.23 |
| `@angular/core` | npm | From 20.0.0-next.0 | 20.3.22 |
| `@angular/core` | npm | From 20.0.0-next.0 | 20.3.22 |
| `@angular/core` | npm | From 21.0.0-next.0 | 21.2.15 |
| `@angular/core` | npm | From 21.0.0-next.0 | 21.2.15 |
| `@angular/core` | npm | From 22.0.0-next.0 | 22.0.0-rc.2 |
| `@angular/core` | npm | From 22.0.0-next.0 | 22.0.0-rc.2 |

Products: Angular Angular.

## How do I fix CVE-2026-52725?

Upgrade @angular/core to a fixed version for your release line: 19.2.23, 20.3.22, 21.2.15 or 22.0.0-rc.2.

## Is CVE-2026-52725 being exploited?

There is no known exploitation of CVE-2026-52725 in the wild and no public exploit code.

## Other vulnerabilities in angular

- [CVE-2026-68945](https://insights.sbomify.com/CVE-2026-68945/): Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning (high 8.8)
- [CVE-2026-46417](https://insights.sbomify.com/CVE-2026-46417/): Angular: SSRF via Hostname Hijacking in @angular/platform-server (high 8.8)
- [CVE-2026-50168](https://insights.sbomify.com/CVE-2026-50168/): Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass (high 8.8)
- [CVE-2026-54266](https://insights.sbomify.com/CVE-2026-54266/): Angular: Weak 32-Bit Cache Key Hashing in `HttpTransferCache` Leading to Cross-Request Data Leakage and State Poisoning (high 8.8)
- [CVE-2026-41423](https://insights.sbomify.com/CVE-2026-41423/): Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52725 and fix it if it is affected.

What it is: CVE-2026-52725 is a medium-severity cross-site scripting vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-52725 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/core (npm): affected all versions up to 18.2.14; no fix listed
- @angular/core (npm): affected all versions up to 18.2.14; no fix listed
- @angular/core (npm): affected from 19.0.0-next.0; fixed in 19.2.23
- @angular/core (npm): affected from 19.0.0-next.0; fixed in 19.2.23
- @angular/core (npm): affected from 20.0.0-next.0; fixed in 20.3.22
- @angular/core (npm): affected from 20.0.0-next.0; fixed in 20.3.22
- @angular/core (npm): affected from 21.0.0-next.0; fixed in 21.2.15
- @angular/core (npm): affected from 21.0.0-next.0; fixed in 21.2.15
- @angular/core (npm): affected from 22.0.0-next.0; fixed in 22.0.0-rc.2
- @angular/core (npm): affected from 22.0.0-next.0; fixed in 22.0.0-rc.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52725/ (Markdown: https://insights.sbomify.com/CVE-2026-52725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52725
- OSV: https://osv.dev/vulnerability/CVE-2026-52725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52725/
Summaries are generated and may contain mistakes; the official description above is the record.
