CVE-2026-52735 ZEBRA: Consensus divergence via P2SH sigop undercount in pure-Rust disabled-opcode parser

Critical 9.3 Published Updated

An attacker can cause a consensus chain split in Zebra nodes by exploiting a signature operation counting error, leading to network availability issues.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-52735?

CVE-2026-52735 is a critical denial of service vulnerability in ZcashFoundation zebra, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

ZEBRA is a Zcash node written entirely in Rust. Prior to 4.5.0, Zebra can accept a block that zcashd rejects because the P2SH signature-operation counter undercounts redeem scripts containing a disabled opcode followed by signature opcodes. In zebra-script/src/lib.rs, p2sh_input_sigop_count used the pure-Rust script::Code::sig_op_count path, whose try_fold parser stops at disabled opcodes such as OP_CODESEPARATOR and returns only the partial count accumulated before the error. The zcashd reference implementation continues static signature-operation counting through disabled opcodes, so an attacker can broadcast P2SH spends that Zebra counts below MAX_BLOCK_SIGOPS while zcashd counts above the 20,000-operation limit. If a Zebra miner includes those transactions, Zebra validators accept the block while zcashd validators reject it, creating a consensus chain split that affects network integrity and availability without requiring the attacker to produce a block. This issue is fixed in version 4.5.0.

Weakness: CWE-684

Which versions are affected by CVE-2026-52735?

4 open source packages ship an affected version, including zebra-script and zebrad.

PackageAffectedFixed in
zebra-script crates.ioAll versions7.0.0
zebra-script crates.ioAll versions7.0.0
zebrad crates.ioAll versions4.5.0
zebrad crates.ioAll versions4.5.0

How do I fix CVE-2026-52735?

Upgrade zebra-script to 7.0.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-52735 being exploited?

There is no known exploitation of CVE-2026-52735 in the wild and no public exploit code.

Sources

Also known as GHSA-gf9r-m956-97qx.

Is CVE-2026-52735 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free