{"answers":{"affected":"2 open source packages ship an affected version, including yeswiki/yeswiki.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52762 exists.","fix":"Upgrade yeswiki/yeswiki to 4.6.6 or later.","what":"CVE-2026-52762 is a high-severity code injection vulnerability in yeswiki, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-52762 and fix it if it is affected.\n\nWhat it is: CVE-2026-52762 is a high-severity code injection vulnerability in yeswiki, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52762 exists.\n\nAffected packages and fixed versions:\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-52762/ (Markdown: https://insights.sbomify.com/CVE-2026-52762/index.md)","id":"CVE-2026-52762","markdown":"https://insights.sbomify.com/CVE-2026-52762/index.md","name":"CVE-2026-52762","record":{"aliases":["GHSA-65p8-9433-jpcp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"YesWiki wiki system","requires_auth":"low_privilege","summary":"An authenticated administrator can achieve remote code execution by injecting Twig expressions into semantic templates in YesWiki.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"YesWiki is a wiki system written in PHP. Prior to version 4.6.6, YesWiki Bazar contains a stored Server-Side Template Injection (SSTI) vulnerability in the semantic template feature that can be escalated to confirmed Remote Code Execution (RCE). An authenticated administrator can place arbitrary Twig expressions into the Semantic template (Twig) field (bn_sem_template), and that content is later executed server-side when public semantic endpoints are requested. This issue has been patched in version 4.6.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"YesWiki: Authenticated (Admin) Server-Side Template Injection to Remote Code Execution via Bazar Semantic Templates","id":"CVE-2026-52762","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"YesWiki: SQL injection via the `recentchanges` action `period` argument leading to arbitrary DB read","id":"CVE-2026-52763"},"packages":[{"ecosystem":"Packagist","fixed":["4.6.6"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":null,"source":"GHSA-65p8-9433-jpcp"},{"ecosystem":"Packagist","fixed":["4.6.6"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":"pkg:composer/yeswiki/yeswiki","source":"GHSA-65p8-9433-jpcp"}],"prev":{"headline":"ModSecurity: Transformation utf8toUnicode produces wrong output on i386 architecture","id":"CVE-2026-52761"},"products":["yeswiki"],"published":"2026-09-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-08","vendors":["YesWiki"]},"summary":"An authenticated administrator can achieve remote code execution by injecting Twig expressions into semantic templates in YesWiki.","url":"https://insights.sbomify.com/CVE-2026-52762/"}