# CVE-2026-52762: YesWiki: Authenticated (Admin) Server-Side Template Injection to Remote Code Execution via Bazar Semantic Templates

> An authenticated administrator can achieve remote code execution by injecting Twig expressions into semantic templates in YesWiki.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** GHSA-65p8-9433-jpcp

## What is CVE-2026-52762?

CVE-2026-52762 is a high-severity code injection vulnerability in yeswiki, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.6.6, YesWiki Bazar contains a stored Server-Side Template Injection (SSTI) vulnerability in the semantic template feature that can be escalated to confirmed Remote Code Execution (RCE). An authenticated administrator can place arbitrary Twig expressions into the Semantic template (Twig) field (bn_sem_template), and that content is later executed server-side when public semantic endpoints are requested. This issue has been patched in version 4.6.6.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-52762?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |

## How do I fix CVE-2026-52762?

Upgrade yeswiki/yeswiki to 4.6.6 or later.

## Is CVE-2026-52762 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52762 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52762 and fix it if it is affected.

What it is: CVE-2026-52762 is a high-severity code injection vulnerability in yeswiki, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52762 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52762/ (Markdown: https://insights.sbomify.com/CVE-2026-52762/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52762
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52762
- OSV: https://osv.dev/vulnerability/CVE-2026-52762

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52762/
Summaries are generated and may contain mistakes; the official description above is the record.
