# CVE-2026-52766: YesWiki: Unauthenticated arbitrary page deletion via `{{erasespamedcomments}}` action

> Unauthenticated attackers can delete arbitrary wiki pages due to missing authorization checks in the erasespamedcomments action.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 9 Sep 2026
- **Also known as:** GHSA-6x7x-gcmf-7r8x

## What is CVE-2026-52766?

CVE-2026-52766 is a critical missing authorization vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.6.6, the {{erasespamedcomments}} wiki action (actions/EraseSpamedCommentsAction.php) accepts a suppr[] array from POST and deletes every wiki page whose tag appears in that array, with no authorization check anywhere in the action body or in the page-deletion path it invokes. Combined with YesWiki's allow-by-default action ACL model, any user who has page write access, which is the default for everyone (default_write_acl='*') on a fresh install can permanently delete arbitrary wiki pages, including the front page, admin pages, and pages owned by other users. This issue has been patched in version 4.6.6.

Weakness: CWE-862 (Missing Authorization), CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2026-52766?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |

## How do I fix CVE-2026-52766?

Upgrade yeswiki/yeswiki to 4.6.6 or later.

## Is CVE-2026-52766 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52766 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52766 and fix it if it is affected.

What it is: CVE-2026-52766 is a critical missing authorization vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52766 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52766/ (Markdown: https://insights.sbomify.com/CVE-2026-52766/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52766
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52766
- OSV: https://osv.dev/vulnerability/CVE-2026-52766

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52766/
Summaries are generated and may contain mistakes; the official description above is the record.
