# CVE-2026-52767: YesWiki: Unauthenticated ActivityPub Signature-Verification Bypass via `!openssl_verify(...)` accepting `int(-1)`

> Attackers can bypass ActivityPub signature verification in YesWiki by exploiting PHP truthiness rules, allowing unauthenticated processing of malicious payloads.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** GHSA-mv28-wj57-f57g

## What is CVE-2026-52767?

CVE-2026-52767 is a high-severity vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. From version 4.6.2 to before version 4.6.6, HttpSignatureService::verifySignature() checks the result of PHP's openssl_verify() with a loose boolean negation - if (!openssl_verify(...)) { throw ... }. PHP's openssl_verify has four possible return values: 1, 0, -1, and "false". The -1 row is the bypass: PHP's truthiness rules make -1 a truthy value, so !(-1) === false, the throw is skipped, and the controller proceeds to processActivity(). Any condition that makes OpenSSL's EVP_VerifyFinal() return -1 triggers the bypass. The reachable consequence is the controller silently treats a failed verification as success and processes the attacker's payload. This issue has been patched in version 4.6.6.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-52767?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | From 4.6.2 | 4.6.6 |
| `yeswiki/yeswiki` | Packagist | From 4.6.2 | 4.6.6 |

## How do I fix CVE-2026-52767?

Upgrade yeswiki/yeswiki to 4.6.6 or later.

## Is CVE-2026-52767 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52767 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52767 and fix it if it is affected.

What it is: CVE-2026-52767 is a high-severity vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52767 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected from 4.6.2; fixed in 4.6.6
- yeswiki/yeswiki (Packagist): affected from 4.6.2; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52767/ (Markdown: https://insights.sbomify.com/CVE-2026-52767/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52767
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52767
- OSV: https://osv.dev/vulnerability/CVE-2026-52767

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52767/
Summaries are generated and may contain mistakes; the official description above is the record.
