# CVE-2026-52770: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') in yeswiki/yeswiki

> Unauthenticated attackers can inject SQL into YesWiki's Bazar entry-listing APIs to infer database contents via boolean-based blind injection.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** GHSA-qg78-vmvc-fhjw

## What is CVE-2026-52770?

CVE-2026-52770 is a high-severity SQL injection vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.6.6, YesWiki’s public Bazar entry-listing APIs are vulnerable to unauthenticated SQL injection in numeric query / queries filters. For Bazar fields whose value structure is numeric, YesWiki escapes the attacker-controlled filter value but inserts it into SQL without quotes or numeric validation. An unauthenticated attacker can inject boolean SQL expressions and infer database contents from whether entries are returned. This issue has been patched in version 4.6.6.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-52770?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |

## How do I fix CVE-2026-52770?

Upgrade yeswiki/yeswiki to 4.6.6 or later.

## Is CVE-2026-52770 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52770 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52770 and fix it if it is affected.

What it is: CVE-2026-52770 is a high-severity SQL injection vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52770 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52770/ (Markdown: https://insights.sbomify.com/CVE-2026-52770/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52770
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52770
- OSV: https://osv.dev/vulnerability/CVE-2026-52770

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52770/
Summaries are generated and may contain mistakes; the official description above is the record.
