# CVE-2026-52771: YesWiki: Second-Order SQL Injection in Page Delete API via Unescaped Page Tag (`ApiController::deletePage`)

> A low-privilege user can execute arbitrary SQL queries via second-order injection in the page delete API, allowing data exfiltration or modification.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** GHSA-8f2v-2qhj-gfwg

## What is CVE-2026-52771?

CVE-2026-52771 is a high-severity SQL injection vulnerability in yeswiki, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. From version 4.2.0 to before version 4.6.6, ApiController::deletePage() interpolates a page tag retrieved from the database into a DELETE FROM …_links WHERE to_tag = '$tag' query without escaping. The page tag is attacker-controlled — the POST /api/pages/{tag} API accepts arbitrary URL-encoded values, including single quotes, and stores them. A low-privilege authenticated user can therefore create a page whose tag is a SQL fragment, make the page non-orphaned via the standard {{include page="…"}} link mechanism, and then invoke the delete endpoint to execute arbitrary SQL inside the wiki database - including time-based blind data exfiltration from any table. This issue has been patched in version 4.6.6.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-52771?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | From 4.2.0 | 4.6.6 |
| `yeswiki/yeswiki` | Packagist | From 4.2.0 | 4.6.6 |

## How do I fix CVE-2026-52771?

Upgrade yeswiki/yeswiki to 4.6.6 or later.

## Is CVE-2026-52771 being exploited?

There is no known exploitation of CVE-2026-52771 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52771 and fix it if it is affected.

What it is: CVE-2026-52771 is a high-severity SQL injection vulnerability in yeswiki, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-52771 in the wild and no public exploit code.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected from 4.2.0; fixed in 4.6.6
- yeswiki/yeswiki (Packagist): affected from 4.2.0; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52771/ (Markdown: https://insights.sbomify.com/CVE-2026-52771/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52771
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52771
- OSV: https://osv.dev/vulnerability/CVE-2026-52771

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52771/
Summaries are generated and may contain mistakes; the official description above is the record.
