# CVE-2026-52772: YesWiki has stored XSS in Bazar form-field templates via unescaped field.label / field.hint (|raw('html'))

> Attackers can inject malicious scripts via Bazar form fields, leading to stored XSS and potential account takeover in YesWiki.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 9 Sep 2026
- **Also known as:** GHSA-xc7j-3g8q-9vh4

## What is CVE-2026-52772?

CVE-2026-52772 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 4 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.6.6, Bazar form-field templates still apply |raw('html') to field.label / field.hint in attribute and label-body contexts, resulting stored XSS in form renders. This issue has been patched in version 4.6.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-52772?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |

## How do I fix CVE-2026-52772?

Upgrade yeswiki/yeswiki to 4.6.6 or later.

## Is CVE-2026-52772 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52772 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52772 and fix it if it is affected.

What it is: CVE-2026-52772 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 4 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52772 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52772/ (Markdown: https://insights.sbomify.com/CVE-2026-52772/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52772
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52772
- OSV: https://osv.dev/vulnerability/CVE-2026-52772

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52772/
Summaries are generated and may contain mistakes; the official description above is the record.
