{"answers":{"affected":"2 open source packages ship an affected version, including yeswiki/yeswiki.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52773 exists.","fix":"Upgrade yeswiki/yeswiki to 4.6.6 or later.","what":"CVE-2026-52773 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-52773 and fix it if it is affected.\n\nWhat it is: CVE-2026-52773 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52773 exists.\n\nAffected packages and fixed versions:\n- yeswiki/yeswiki (Packagist): affected from 4.1.0; fixed in 4.6.6\n- yeswiki/yeswiki (Packagist): affected from 4.1.0; fixed in 4.6.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-52773/ (Markdown: https://insights.sbomify.com/CVE-2026-52773/index.md)","id":"CVE-2026-52773","markdown":"https://insights.sbomify.com/CVE-2026-52773/index.md","name":"CVE-2026-52773","record":{"aliases":["GHSA-35f3-pg38-486f"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"YesWiki","requires_auth":"none","summary":"Reflected XSS in YesWiki allows attackers to execute arbitrary JavaScript via the time parameter, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"YesWiki is a wiki system written in PHP. From version 4.1.0 to before version 4.6.6, YesWiki's archived-revision view reflects the time GET parameter into a hidden HTML input in handlers/page/show.php without escaping. Because MySQL coerces malformed DATETIME strings, an attacker can append HTML or JavaScript to a valid archived revision timestamp, still load that archived revision, and execute arbitrary JavaScript in the victim's browser. The vulnerable form is only rendered when the victim can both read and edit the target page. In restricted deployments this requires a victim with read and write access to that page. On a default doryphore 4.6.5 install, public pages such as PagePrincipale were editable anonymously during validation, so the issue can also affect unauthenticated visitors in that configuration. This issue has been patched in version 4.6.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2026/CVE-2026-52773.yaml","stars":null,"title":"YesWiki Archived Revision - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Reflected XSS via Unescaped Archived-Revision `time` Parameter in `handlers/page/show.php` in YesWiki","id":"CVE-2026-52773","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Reflected XSS via Unescaped `id` Parameter in Bazar Widget HTML Attributes in YesWiki","id":"CVE-2026-52774"},"packages":[{"ecosystem":"Packagist","fixed":["4.6.6"],"introduced":["4.1.0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":null,"source":"GHSA-35f3-pg38-486f"},{"ecosystem":"Packagist","fixed":["4.6.6"],"introduced":["4.1.0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":"pkg:composer/yeswiki/yeswiki","source":"GHSA-35f3-pg38-486f"}],"prev":{"headline":"YesWiki has stored XSS in Bazar form-field templates via unescaped field.label / field.hint (|raw('html'))","id":"CVE-2026-52772"},"products":["yeswiki"],"published":"2026-09-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-08","vendors":["YesWiki"]},"summary":"Reflected XSS in YesWiki allows attackers to execute arbitrary JavaScript via the time parameter, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2026-52773/"}