# CVE-2026-52773: Reflected XSS via Unescaped Archived-Revision `time` Parameter in `handlers/page/show.php` in YesWiki

> Reflected XSS in YesWiki allows attackers to execute arbitrary JavaScript via the time parameter, potentially leading to account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** GHSA-35f3-pg38-486f

## What is CVE-2026-52773?

CVE-2026-52773 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

YesWiki is a wiki system written in PHP. From version 4.1.0 to before version 4.6.6, YesWiki's archived-revision view reflects the time GET parameter into a hidden HTML input in handlers/page/show.php without escaping. Because MySQL coerces malformed DATETIME strings, an attacker can append HTML or JavaScript to a valid archived revision timestamp, still load that archived revision, and execute arbitrary JavaScript in the victim's browser. The vulnerable form is only rendered when the victim can both read and edit the target page. In restricted deployments this requires a victim with read and write access to that page. On a default doryphore 4.6.5 install, public pages such as PagePrincipale were editable anonymously during validation, so the issue can also affect unauthenticated visitors in that configuration. This issue has been patched in version 4.6.6.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-52773?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | From 4.1.0 | 4.6.6 |
| `yeswiki/yeswiki` | Packagist | From 4.1.0 | 4.6.6 |

## How do I fix CVE-2026-52773?

Upgrade yeswiki/yeswiki to 4.6.6 or later.

## Is CVE-2026-52773 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52773 exists.

Public exploit code:

- YesWiki Archived Revision - Cross-Site Scripting (nuclei): http/cves/2026/CVE-2026-52773.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52773 and fix it if it is affected.

What it is: CVE-2026-52773 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52773 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected from 4.1.0; fixed in 4.6.6
- yeswiki/yeswiki (Packagist): affected from 4.1.0; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52773/ (Markdown: https://insights.sbomify.com/CVE-2026-52773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52773
- OSV: https://osv.dev/vulnerability/CVE-2026-52773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52773/
Summaries are generated and may contain mistakes; the official description above is the record.
