# CVE-2026-52774: Reflected XSS via Unescaped `id` Parameter in Bazar Widget HTML Attributes in YesWiki

> Attackers can execute arbitrary JavaScript in victims' browsers via reflected XSS in the Bazar widget, requiring the extension to be enabled.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** GHSA-r5xw-gcgw-hwp5

## What is CVE-2026-52774?

CVE-2026-52774 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.6.6, YesWiki's Bazar widget handler reflects the id GET parameter into HTML attributes using strip_tags() only. Because strip_tags() does not escape double quotes, an attacker can break out of the attribute value, inject an event handler such as onmouseover, and execute arbitrary JavaScript in the victim's browser. This issue is reachable without authentication. During validation, the vulnerable widget route returned the injected HTML for both /HomePage/widget?id=... and /NoSuchPage/widget?id=..., which shows that no login, no page ownership, no edit rights, and not even a valid page tag were required. The only routing prerequisite observed was that the Bazar extension is enabled and the request includes an id parameter. This issue has been patched in version 4.6.6.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-52774?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |

## How do I fix CVE-2026-52774?

Upgrade yeswiki/yeswiki to 4.6.6 or later.

## Is CVE-2026-52774 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52774 exists.

Public exploit code:

- a reflected XSS vulnerability in YesWiki's Bazar widget handler. (github_poc): https://github.com/0xTerror/CVE-2026-52774-YESWIKI-XSS
- YesWiki Bazar Widget - Reflected XSS via 'id' Parameter (nuclei): http/cves/2026/CVE-2026-52774.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52774 and fix it if it is affected.

What it is: CVE-2026-52774 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52774 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52774/ (Markdown: https://insights.sbomify.com/CVE-2026-52774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52774
- OSV: https://osv.dev/vulnerability/CVE-2026-52774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52774/
Summaries are generated and may contain mistakes; the official description above is the record.
