# CVE-2026-52775: YesWiki Authenticated SQL Injection in ReactionManager

> Authenticated users can inject arbitrary SQL via URL parameters in YesWiki, allowing unauthorized data access or modification.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** GHSA-4pf7-cc4r-g63h

## What is CVE-2026-52775?

CVE-2026-52775 is a high-severity SQL injection vulnerability in yeswiki, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.6.6, YesWiki through the latest development branch contains a SQL injection vulnerability in ReactionManager::deleteUserReaction() that allows any authenticated user to inject arbitrary SQL via the {idreaction} and {id} URL path parameters. The parameters are concatenated directly into a SQL LIKE clause without escaping or parameterization. This issue has been patched in version 4.6.6.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-52775?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |

## How do I fix CVE-2026-52775?

Upgrade yeswiki/yeswiki to 4.6.6 or later.

## Is CVE-2026-52775 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52775 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52775 and fix it if it is affected.

What it is: CVE-2026-52775 is a high-severity SQL injection vulnerability in yeswiki, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52775 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52775/ (Markdown: https://insights.sbomify.com/CVE-2026-52775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52775
- OSV: https://osv.dev/vulnerability/CVE-2026-52775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52775/
Summaries are generated and may contain mistakes; the official description above is the record.
