CVE-2026-52776 Trestle URLSecurityValidator SSRF allowlist bypass via IPv4-mapped IPv6 and 0.0.0.0
Attackers can bypass SSRF protections in Trestle to access internal network resources and cloud metadata via crafted IPv6 or unspecified addresses.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-52776?
CVE-2026-52776 is a high-severity server-side request forgery vulnerability in oscal-compass compliance-trestle, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Compliance-trestle (Trestle) is a tooling platform for managing compliance as code. In versions before 3.12.4 and versions 4.0.0 through 4.0.3, the URLSecurityValidator that guards trestle's remote-fetch paths against server-side request forgery can be bypassed to reach loopback, link-local, cloud-metadata, and internal network endpoints it was designed to block. The blocklist does not canonicalize IPv4-mapped IPv6 literals such as [::ffff:169.254.169.254], which resolve to IPv6Address objects that never match the blocked IPv4 ranges, and it does not block the unspecified address 0.0.0.0, which routes to local services on Linux and inside containers. An attacker who can supply or influence an OSCAL artifact that trestle fetches, such as a malicious profile whose imports reference one of these bypass URLs, can cause the HTTPSFetcher and SFTPFetcher paths to contact cloud instance-metadata services, loopback interfaces, or internal hosts. This issue is fixed in versions 3.12.4 and 4.1.0.
Which versions are affected by CVE-2026-52776?
3 open source packages ship an affected version, including compliance-trestle.
| Package | Affected | Fixed in |
|---|---|---|
compliance-trestle PyPI | All versions | 4.1.0 |
compliance-trestle PyPI | All versions | 4.1.0 |
compliance-trestle PyPI | All versions | 4.1.0 |
How do I fix CVE-2026-52776?
Upgrade compliance-trestle to 4.1.0 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-52776 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52776 exists.
Sources
Also known as GHSA-h47f-gmjp-m7rr, PYSEC-2026-3659.