# CVE-2026-52777: YesWiki: Authenticated PHP Object Injection in BazarImportAction via unserialize

> Authenticated attackers can achieve code execution in YesWiki via unsafe deserialization in the BazarImportAction component.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** GHSA-9369-69wj-7m2f

## What is CVE-2026-52777?

CVE-2026-52777 is a critical unsafe deserialization vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.6.6, there is an authenticated PHP object injection vulnerability in BazarImportAction via unserialize. This issue has been patched in version 4.6.6.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-52777?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |

## How do I fix CVE-2026-52777?

Upgrade yeswiki/yeswiki to 4.6.6 or later.

## Is CVE-2026-52777 being exploited?

There is no known exploitation of CVE-2026-52777 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52777 and fix it if it is affected.

What it is: CVE-2026-52777 is a critical unsafe deserialization vulnerability in yeswiki, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-52777 in the wild and no public exploit code.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52777/ (Markdown: https://insights.sbomify.com/CVE-2026-52777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52777
- OSV: https://osv.dev/vulnerability/CVE-2026-52777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52777/
Summaries are generated and may contain mistakes; the official description above is the record.
