{"answers":{"affected":"2 open source packages ship an affected version, including yeswiki/yeswiki.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52778 exists.","fix":"Upgrade yeswiki/yeswiki to 4.6.6 or later.","what":"CVE-2026-52778 is a critical code injection vulnerability in yeswiki, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-52778 and fix it if it is affected.\n\nWhat it is: CVE-2026-52778 is a critical code injection vulnerability in yeswiki, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52778 exists.\n\nAffected packages and fixed versions:\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-52778/ (Markdown: https://insights.sbomify.com/CVE-2026-52778/index.md)","id":"CVE-2026-52778","markdown":"https://insights.sbomify.com/CVE-2026-52778/index.md","name":"CVE-2026-52778","record":{"aliases":["GHSA-px5m-h76g-p7p8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"YesWiki wiki system","requires_auth":"none","summary":"Attackers can execute arbitrary PHP code or crash the server via unsafe eval() in YesWiki's formula calculator.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"YesWiki is a wiki system written in PHP. Prior to version 4.6.6, an unsafe execution vulnerability exists in the Bazar form field calculator (CalcField.php) of YesWiki. The application attempts to sanitize user-defined mathematical formulas using a complex recursive regular expression before passing them to the PHP eval() function. This implementation is inherently flawed: it is vulnerable to Regular Expression Denial of Service (ReDoS / Stack Overflow) which can crash the server, and it creates a high-risk architecture where any logic bypass directly results in arbitrary PHP code execution. Version 4.6.6 patches the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"YesWiki has Unsafe eval() in Formula Calculator - Remote Code Execution (RCE) \u0026 Denial of Service (DoS)","id":"CVE-2026-52778","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Missing authorization in openproject","id":"CVE-2026-52779"},"packages":[{"ecosystem":"Packagist","fixed":["4.6.6"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":null,"source":"GHSA-px5m-h76g-p7p8"},{"ecosystem":"Packagist","fixed":["4.6.6"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":"pkg:composer/yeswiki/yeswiki","source":"GHSA-px5m-h76g-p7p8"}],"prev":{"headline":"YesWiki: Authenticated PHP Object Injection in BazarImportAction via unserialize","id":"CVE-2026-52777"},"products":["yeswiki"],"published":"2026-06-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-09","vendors":["YesWiki"]},"summary":"Attackers can execute arbitrary PHP code or crash the server via unsafe eval() in YesWiki's formula calculator.","url":"https://insights.sbomify.com/CVE-2026-52778/"}