# CVE-2026-52778: YesWiki has Unsafe eval() in Formula Calculator - Remote Code Execution (RCE) & Denial of Service (DoS)

> Attackers can execute arbitrary PHP code or crash the server via unsafe eval() in YesWiki's formula calculator.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2026
- **Updated:** 9 Jun 2026
- **Also known as:** GHSA-px5m-h76g-p7p8

## What is CVE-2026-52778?

CVE-2026-52778 is a critical code injection vulnerability in yeswiki, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.6.6, an unsafe execution vulnerability exists in the Bazar form field calculator (CalcField.php) of YesWiki. The application attempts to sanitize user-defined mathematical formulas using a complex recursive regular expression before passing them to the PHP eval() function. This implementation is inherently flawed: it is vulnerable to Regular Expression Denial of Service (ReDoS / Stack Overflow) which can crash the server, and it creates a high-risk architecture where any logic bypass directly results in arbitrary PHP code execution. Version 4.6.6 patches the issue.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-52778?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.6 |

## How do I fix CVE-2026-52778?

Upgrade yeswiki/yeswiki to 4.6.6 or later.

## Is CVE-2026-52778 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52778 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52778 and fix it if it is affected.

What it is: CVE-2026-52778 is a critical code injection vulnerability in yeswiki, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52778 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52778/ (Markdown: https://insights.sbomify.com/CVE-2026-52778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52778
- OSV: https://osv.dev/vulnerability/CVE-2026-52778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52778/
Summaries are generated and may contain mistakes; the official description above is the record.
