CVE-2026-52791 fuse-overlayfs release-1.x preserves SUID/SGID bits after truncate/open(O_TRUNC)
A low-privileged process can retain SUID/SGID bits on copied-up files in fuse-overlayfs, enabling privilege escalation in rootless containers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-52791?
CVE-2026-52791 is a low-severity vulnerability in containers fuse-overlayfs, published on 29 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
fuse-overlayfs is an implementation of overlayfs in FUSE for rootless containers. Prior to 1.17, the release-1.x C branch preserves SUID and SGID mode bits in main.c during open(O_TRUNC) and truncate handling on a copied-up file, allowing a low-privileged process to leave the upper-layer file with mode 4777. This issue is fixed in version 1.17.
Weakness: CWE-266
Which versions are affected by CVE-2026-52791?
Linux distribution packages (12)
fuse-overlayfs Red Hat:hummingbird:1 | All versions | 0:1.17-1.hum1 |
fuse-overlayfs SUSE:Enterprise Storage 7.1 | All versions | 1.1.2-150100.3.14.1 |
fuse-overlayfs SUSE:Linux Enterprise Micro 5.3 | All versions | 1.1.2-150100.3.14.1 |
fuse-overlayfs SUSE:Linux Enterprise Micro 5.4 | All versions | 1.1.2-150100.3.14.1 |
fuse-overlayfs SUSE:Linux Enterprise Micro 5.5 | All versions | 1.1.2-150100.3.14.1 |
fuse-overlayfs SUSE:Linux Enterprise Module for Containers 15 SP7 | All versions | 1.1.2-150100.3.14.1 |
fuse-overlayfs SUSE:Linux Enterprise Server 16.0 | All versions | 1.15-160000.3.1 |
fuse-overlayfs SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 1.15-160000.3.1 |
fuse-overlayfs SUSE:Linux Micro 6.0 | All versions | 1.12-2.1 |
fuse-overlayfs SUSE:Linux Micro 6.2 | All versions | 1.15-160000.3.1 |
fuse-overlayfs openSUSE:Leap 16.0 | All versions | 1.15-160000.3.1 |
fuse-overlayfs openSUSE:Tumbleweed | All versions | 1.17-1.1 |
How do I fix CVE-2026-52791?
Upgrade to a fixed version.
Is CVE-2026-52791 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52791 exists.
Sources
Also known as AZL-94145, DEBIAN-CVE-2026-52791, GHSA-2cc4-p72c-v85h, RHSA-2026:52805, SUSE-SU-2026:23252-1, SUSE-SU-2026:23469-1 and 5 more.