# CVE-2026-52791: fuse-overlayfs release-1.x preserves SUID/SGID bits after truncate/open(O_TRUNC)

> A low-privileged process can retain SUID/SGID bits on copied-up files in fuse-overlayfs, enabling privilege escalation in rootless containers.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** AZL-94145, DEBIAN-CVE-2026-52791, GHSA-2cc4-p72c-v85h, RHSA-2026:52805, SUSE-SU-2026:23252-1, SUSE-SU-2026:23469-1, SUSE-SU-2026:23618-1, SUSE-SU-2026:4026-1, UBUNTU-CVE-2026-52791, openSUSE-SU-2026:11461-1, openSUSE-SU-2026:21753-1

## What is CVE-2026-52791?

CVE-2026-52791 is a low-severity vulnerability in containers fuse-overlayfs, published on 29 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

fuse-overlayfs is an implementation of overlayfs in FUSE for rootless containers. Prior to 1.17, the release-1.x C branch preserves SUID and SGID mode bits in main.c during open(O_TRUNC) and truncate handling on a copied-up file, allowing a low-privileged process to leave the upper-layer file with mode 4777. This issue is fixed in version 1.17.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2026-52791?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fuse-overlayfs` | Red Hat:hummingbird:1 | All versions | 0:1.17-1.hum1 |
| `fuse-overlayfs` | SUSE:Enterprise Storage 7.1 | All versions | 1.1.2-150100.3.14.1 |
| `fuse-overlayfs` | SUSE:Linux Enterprise Micro 5.3 | All versions | 1.1.2-150100.3.14.1 |
| `fuse-overlayfs` | SUSE:Linux Enterprise Micro 5.4 | All versions | 1.1.2-150100.3.14.1 |
| `fuse-overlayfs` | SUSE:Linux Enterprise Micro 5.5 | All versions | 1.1.2-150100.3.14.1 |
| `fuse-overlayfs` | SUSE:Linux Enterprise Module for Containers 15 SP7 | All versions | 1.1.2-150100.3.14.1 |
| `fuse-overlayfs` | SUSE:Linux Enterprise Server 16.0 | All versions | 1.15-160000.3.1 |
| `fuse-overlayfs` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 1.15-160000.3.1 |
| `fuse-overlayfs` | SUSE:Linux Micro 6.0 | All versions | 1.12-2.1 |
| `fuse-overlayfs` | SUSE:Linux Micro 6.2 | All versions | 1.15-160000.3.1 |
| `fuse-overlayfs` | openSUSE:Leap 16.0 | All versions | 1.15-160000.3.1 |
| `fuse-overlayfs` | openSUSE:Tumbleweed | All versions | 1.17-1.1 |

## How do I fix CVE-2026-52791?

Upgrade to a fixed version.

## Is CVE-2026-52791 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52791 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52791 and fix it if it is affected.

What it is: CVE-2026-52791 is a low-severity vulnerability in containers fuse-overlayfs, published on 29 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52791 exists.

Affected product: containers fuse-overlayfs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52791/ (Markdown: https://insights.sbomify.com/CVE-2026-52791/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52791
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52791
- OSV: https://osv.dev/vulnerability/CVE-2026-52791

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52791/
Summaries are generated and may contain mistakes; the official description above is the record.
