{"answers":{"affected":"2 open source packages ship an affected version, including froxlor/froxlor.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52793 exists.","fix":"Upgrade froxlor/froxlor to 2.3.7 or later.","what":"CVE-2026-52793 is a high-severity authentication bypass vulnerability in froxlor, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-52793 and fix it if it is affected.\n\nWhat it is: CVE-2026-52793 is a high-severity authentication bypass vulnerability in froxlor, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52793 exists.\n\nAffected packages and fixed versions:\n- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.7\n- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-52793/ (Markdown: https://insights.sbomify.com/CVE-2026-52793/index.md)","id":"CVE-2026-52793","markdown":"https://insights.sbomify.com/CVE-2026-52793/index.md","name":"CVE-2026-52793","record":{"aliases":["GHSA-f9rx-7wf7-jr36"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Server administration software","requires_auth":"low_privilege","summary":"Attackers with valid API keys can bypass two-factor authentication to access and modify sensitive server configuration data.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Froxlor is open source server administration software. Prior to 2.3.7, the API authentication path in lib/Froxlor/Api/FroxlorRPC.php and FroxlorRPC::validateAuth accepts an API key and secret for an administrator or customer account without checking type_2fa, validating a TOTP code, or invoking FroxlorTwoFactorAuth. The web interface requires a second factor for accounts with two-factor authentication enabled, but the API grants access after validating only the API credentials, expiration, API permission, and account status. An attacker who obtains an API key and secret for a protected account can call the available API functions without supplying the configured second factor, which can expose or modify customer data, domains, email and FTP accounts, databases, DNS records, and certificate material. This issue is fixed in version 2.3.7.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Froxlor: API Authentication bypasses 2FA Authentication","id":"CVE-2026-52793","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Sentry: Inefficient Regular Expression Complexity in sentry","id":"CVE-2026-52794"},"packages":[{"ecosystem":"Packagist","fixed":["2.3.7"],"introduced":["0"],"last_affected":[],"package":"froxlor/froxlor","purl":null,"source":"GHSA-f9rx-7wf7-jr36"},{"ecosystem":"Packagist","fixed":["2.3.7"],"introduced":["0"],"last_affected":[],"package":"froxlor/froxlor","purl":"pkg:composer/froxlor/froxlor","source":"GHSA-f9rx-7wf7-jr36"}],"prev":{"headline":"Algernon: Server-side script source disclosure on Windows via NTFS filename","id":"CVE-2026-52792"},"products":["froxlor"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-19","vendors":["froxlor"]},"summary":"Attackers with valid API keys can bypass two-factor authentication to access and modify sensitive server configuration data.","url":"https://insights.sbomify.com/CVE-2026-52793/"}