# CVE-2026-52793: Froxlor: API Authentication bypasses 2FA Authentication

> Attackers with valid API keys can bypass two-factor authentication to access and modify sensitive server configuration data.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-f9rx-7wf7-jr36

## What is CVE-2026-52793?

CVE-2026-52793 is a high-severity authentication bypass vulnerability in froxlor, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Froxlor is open source server administration software. Prior to 2.3.7, the API authentication path in lib/Froxlor/Api/FroxlorRPC.php and FroxlorRPC::validateAuth accepts an API key and secret for an administrator or customer account without checking type_2fa, validating a TOTP code, or invoking FroxlorTwoFactorAuth. The web interface requires a second factor for accounts with two-factor authentication enabled, but the API grants access after validating only the API credentials, expiration, API permission, and account status. An attacker who obtains an API key and secret for a protected account can call the available API functions without supplying the configured second factor, which can expose or modify customer data, domains, email and FTP accounts, databases, DNS records, and certificate material. This issue is fixed in version 2.3.7.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-52793?

2 open source packages ship an affected version, including froxlor/froxlor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.3.7 |
| `froxlor/froxlor` | Packagist | All versions | 2.3.7 |

## How do I fix CVE-2026-52793?

Upgrade froxlor/froxlor to 2.3.7 or later.

## Is CVE-2026-52793 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52793 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52793 and fix it if it is affected.

What it is: CVE-2026-52793 is a high-severity authentication bypass vulnerability in froxlor, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52793 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.7
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52793/ (Markdown: https://insights.sbomify.com/CVE-2026-52793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52793
- OSV: https://osv.dev/vulnerability/CVE-2026-52793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52793/
Summaries are generated and may contain mistakes; the official description above is the record.
