# CVE-2026-52796: Gogs: DoS in rendering issue index pattern

> Attackers can cause a denial of service in Gogs by configuring a malformed issue index pattern that triggers a panic during rendering.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-4j89-2c4f-44c6, GO-2026-5124

## What is CVE-2026-52796?

CVE-2026-52796 is a low-severity denial of service vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Gogs is an open source self-hosted Git service. Prior to 0.14.3, specially crafted issue index pattern can cause a panic when rendering, resulting in denial of service. In internal/markup/markup.go, RenderIssueIndexPattern renders the issue index pattern to a link using com.Expand, which is not safe: when the configured pattern contains an opening brace { but no closing brace }, strings.Index(template, "}") returns -1 and the subsequent slice template[:-1] triggers a panic. Once such a pattern is set, any page in the affected repository that contains an issue index reference such as #1 becomes unavailable. This vulnerability is fixed in 0.14.3.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-52796?

3 open source packages ship an affected version, including gogs.io/gogs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |

## How do I fix CVE-2026-52796?

Upgrade gogs.io/gogs to 0.14.3 or later.

## Is CVE-2026-52796 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52796 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52796 and fix it if it is affected.

What it is: CVE-2026-52796 is a low-severity denial of service vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52796 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52796/ (Markdown: https://insights.sbomify.com/CVE-2026-52796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52796
- OSV: https://osv.dev/vulnerability/CVE-2026-52796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52796/
Summaries are generated and may contain mistakes; the official description above is the record.
