{"answers":{"affected":"3 open source packages ship an affected version, including gogs.io/gogs.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52797 exists.","fix":"Upgrade gogs.io/gogs to 0.14.0 or later.","what":"CVE-2026-52797 is a high-severity path traversal vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-52797 and fix it if it is affected.\n\nWhat it is: CVE-2026-52797 is a high-severity path traversal vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52797 exists.\n\nAffected packages and fixed versions:\n- gogs.io/gogs (Go): affected all versions; no fix listed\n- gogs.io/gogs (Go): affected all versions; fixed in 0.14.0\n- gogs.io/gogs (Go): affected all versions; fixed in 0.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-52797/ (Markdown: https://insights.sbomify.com/CVE-2026-52797/index.md)","id":"CVE-2026-52797","markdown":"https://insights.sbomify.com/CVE-2026-52797/index.md","name":"CVE-2026-52797","record":{"aliases":["GHSA-pm6v-2h4w-4rp2","GO-2026-5545"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Self-hosted Git service","requires_auth":"low_privilege","summary":"An authorized user can overwrite critical files via path traversal in git diff commands, causing denial of service.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Gogs is an open source self-hosted Git service. Prior to 0.14.0, as an authorized user, an intruder can dictate the value which is passed to the git diff command which, together with bypassing the filtering of the passed value, allows the user to bypass the target directory and write the result of the comparison to any arbitrary path. This vulnerability is fixed in 0.14.0.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Gogs: Overwriting critical files results in a denial of service","id":"CVE-2026-52797","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Gogs: Stored XSS in `.ipynb` Preview","id":"CVE-2026-52798"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":"pkg:golang/gogs.io/gogs","source":"GO-2026-5545"},{"ecosystem":"Go","fixed":["0.14.0"],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":null,"source":"GHSA-pm6v-2h4w-4rp2"},{"ecosystem":"Go","fixed":["0.14.0"],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":"pkg:golang/gogs.io/gogs","source":"GHSA-pm6v-2h4w-4rp2"}],"prev":{"headline":"Gogs: DoS in rendering issue index pattern","id":"CVE-2026-52796"},"products":["gogs"],"published":"2026-06-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-25","vendors":["gogs"]},"summary":"An authorized user can overwrite critical files via path traversal in git diff commands, causing denial of service.","url":"https://insights.sbomify.com/CVE-2026-52797/"}