# CVE-2026-52797: Gogs: Overwriting critical files results in a denial of service

> An authorized user can overwrite critical files via path traversal in git diff commands, causing denial of service.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-pm6v-2h4w-4rp2, GO-2026-5545

## What is CVE-2026-52797?

CVE-2026-52797 is a high-severity path traversal vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gogs is an open source self-hosted Git service. Prior to 0.14.0, as an authorized user, an intruder can dictate the value which is passed to the git diff command which, together with bypassing the filtering of the passed value, allows the user to bypass the target directory and write the result of the comparison to any arbitrary path. This vulnerability is fixed in 0.14.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-52797?

3 open source packages ship an affected version, including gogs.io/gogs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.14.0 |
| `gogs.io/gogs` | Go | All versions | 0.14.0 |

## How do I fix CVE-2026-52797?

Upgrade gogs.io/gogs to 0.14.0 or later.

## Is CVE-2026-52797 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52797 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52797 and fix it if it is affected.

What it is: CVE-2026-52797 is a high-severity path traversal vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52797 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.0
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52797/ (Markdown: https://insights.sbomify.com/CVE-2026-52797/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52797
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52797
- OSV: https://osv.dev/vulnerability/CVE-2026-52797

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52797/
Summaries are generated and may contain mistakes; the official description above is the record.
