# CVE-2026-52798: Gogs: Stored XSS in `.ipynb` Preview

> Attackers can execute arbitrary JavaScript in the victim's browser by crafting malicious .ipynb files, potentially leading to account takeover.

- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-jq8v-rmf6-65jw, GO-2026-5477

## What is CVE-2026-52798?

CVE-2026-52798 is a high-severity cross-site scripting vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Gogs is an open source self-hosted Git service. Prior to 0.14.3, although .ipynb previews are sanitized on the server side via /-/api/sanitize_ipynb, the inserted content is re-rendered on the client side without sanitization using marked() on elements with the .nb-markdown-cell class. During this process, links containing schemes such as javascript: can be regenerated. As a result, when a victim views an attacker-crafted .ipynb file and clicks the link, arbitrary JavaScript is executed in the Gogs origin, leading to a click-based Stored XSS. This vulnerability is fixed in 0.14.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-52798?

3 open source packages ship an affected version, including gogs.io/gogs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |

## How do I fix CVE-2026-52798?

Upgrade gogs.io/gogs to 0.14.3 or later.

## Is CVE-2026-52798 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52798 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52798 and fix it if it is affected.

What it is: CVE-2026-52798 is a high-severity cross-site scripting vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52798 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52798/ (Markdown: https://insights.sbomify.com/CVE-2026-52798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52798
- OSV: https://osv.dev/vulnerability/CVE-2026-52798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52798/
Summaries are generated and may contain mistakes; the official description above is the record.
