# CVE-2026-52804: Gogs: Privilege Escalation via Collaboration Access Mode Validation


- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-4565-r4x7-hg8j, GO-2026-5110

## What is CVE-2026-52804?

CVE-2026-52804 is a medium-severity vulnerability in gogs, published on 24 Jun 2026. 

### Official description

Gogs is an open source self-hosted Git service. Prior to 0.14.3, a repository admin collaborator can escalate their privileges to owner-level access by exploiting an off-by-one error in the ChangeCollaborationAccessMode function. This vulnerability is fixed in 0.14.3.

Weakness: CWE-193 (Off-by-one Error)

## Which versions are affected by CVE-2026-52804?

3 open source packages ship an affected version, including gogs.io/gogs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |

## How do I fix CVE-2026-52804?

Upgrade gogs.io/gogs to 0.14.3 or later.

## Is CVE-2026-52804 being exploited?

There is no known exploitation of CVE-2026-52804 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52804 and fix it if it is affected.

What it is: CVE-2026-52804 is a medium-severity vulnerability in gogs, published on 24 Jun 2026. 
Exploitation: There is no known exploitation of CVE-2026-52804 in the wild and no public exploit code.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52804/ (Markdown: https://insights.sbomify.com/CVE-2026-52804/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52804
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52804
- OSV: https://osv.dev/vulnerability/CVE-2026-52804

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52804/
Summaries are generated and may contain mistakes; the official description above is the record.
