# CVE-2026-52805: Gogs: Migration Redirect Bypass Leads to Internal Repository Theft

> An authenticated user can exploit SSRF in repository migration to steal internal repository contents via redirect bypass.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-g2f5-gjr4-qjvm, GO-2026-5387

## What is CVE-2026-52805?

CVE-2026-52805 is a high-severity server-side request forgery vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Gogs is an open source self-hosted Git service. Prior to 0.14.3, a Server-Side Request Forgery (SSRF) vulnerability exists in the repository migration functionality. The application validates only the initially submitted URL hostname, but git clone --mirror follows HTTP redirects. An authenticated user can submit a public URL that redirects to a blocked internal endpoint (e.g., 127.0.0.1), importing the internal repository's contents into an attacker-controlled repository. This vulnerability is fixed in 0.14.3.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-52805?

3 open source packages ship an affected version, including gogs.io/gogs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |

## How do I fix CVE-2026-52805?

Upgrade gogs.io/gogs to 0.14.3 or later.

## Is CVE-2026-52805 being exploited?

There is no known exploitation of CVE-2026-52805 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52805 and fix it if it is affected.

What it is: CVE-2026-52805 is a high-severity server-side request forgery vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-52805 in the wild and no public exploit code.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52805/ (Markdown: https://insights.sbomify.com/CVE-2026-52805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52805
- OSV: https://osv.dev/vulnerability/CVE-2026-52805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52805/
Summaries are generated and may contain mistakes; the official description above is the record.
