# CVE-2026-52810: Gogs: Write to readonly repositories using receive-pack + service=git-upload-pack confusion

> Attackers can push to read-only repositories by exploiting a mismatch between Git smart HTTP authorization and routing logic in Gogs.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-wmfg-5p4h-5fw3, GO-2026-5712

## What is CVE-2026-52810?

CVE-2026-52810 is a high-severity authentication bypass vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gogs is an open source self-hosted Git service. Prior to 0.14.3, Git smart HTTP authorizes POST …/git-receive-pack using the client-supplied service query string (so ?service=git-upload-pack is evaluated as read access) while routing still runs git receive-pack, allowing push where only read should be allowed. This vulnerability is fixed in 0.14.3.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-52810?

3 open source packages ship an affected version, including gogs.io/gogs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |

## How do I fix CVE-2026-52810?

Upgrade gogs.io/gogs to 0.14.3 or later.

## Is CVE-2026-52810 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52810 exists.

Public exploit code:

- CVE-2026-52810 - Draft or TODO (github_poc): https://github.com/HORKimhab/CVE-2026-52810

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52810 and fix it if it is affected.

What it is: CVE-2026-52810 is a high-severity authentication bypass vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52810 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52810/ (Markdown: https://insights.sbomify.com/CVE-2026-52810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52810
- OSV: https://osv.dev/vulnerability/CVE-2026-52810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52810/
Summaries are generated and may contain mistakes; the official description above is the record.
