# CVE-2026-52812: Gogs: LFS dedupe path leaks private repo content across tenants

> An attacker with write access to one repository can download content from private repositories by exploiting Git LFS deduplication logic.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-6p9m-q3jp-47h4, GO-2026-5184

## What is CVE-2026-52812?

CVE-2026-52812 is a high-severity missing authorization vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gogs is an open source self-hosted Git service. Prior to 0.14.3, Git LFS storage is content-addressed by OID alone (<LFS-root>/<oid[0]>/<oid[1]>/<oid>) but per-repo authorization lives in the lfs_object table keyed (repo_id, oid). serveUpload skips re-uploading when the OID file already exists on disk and inserts a new (repo_id, oid) row pointing at it without verifying the request body hashes to the OID being claimed. Any user with write access to one repo can bind their repo to an OID owned by a private repo and download the original bytes via their own download endpoint. This vulnerability is fixed in 0.14.3.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-52812?

3 open source packages ship an affected version, including gogs.io/gogs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |

## How do I fix CVE-2026-52812?

Upgrade gogs.io/gogs to 0.14.3 or later.

## Is CVE-2026-52812 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52812 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52812 and fix it if it is affected.

What it is: CVE-2026-52812 is a high-severity missing authorization vulnerability in gogs, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52812 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52812/ (Markdown: https://insights.sbomify.com/CVE-2026-52812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52812
- OSV: https://osv.dev/vulnerability/CVE-2026-52812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52812/
Summaries are generated and may contain mistakes; the official description above is the record.
