# CVE-2026-52816: Gogs: Unauthenticated Jupyter Notebook (ipynb) Sanitizer allows arbitrary data: URIs leading to XSS

> An unauthenticated user can inject malicious JavaScript via data URIs in Jupyter Notebook sanitization, leading to Cross-Site Scripting.

- **Severity:** Medium 5.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-3w28-36p9-w929, GO-2026-5103

## What is CVE-2026-52816?

CVE-2026-52816 is a medium-severity cross-site scripting vulnerability in gogs, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Gogs is an open source self-hosted Git service. Prior to 0.14.3, the Jupyter Notebook (ipynb) sanitizer endpoint at POST /-/api/sanitize_ipynb allows arbitrary data: URIs without proper restrictions, potentially leading to Cross-Site Scripting (XSS). The endpoint uses bluemonday.UGCPolicy() with p.AllowURLSchemes("data") which permits all data URI schemes including data:text/html, enabling attackers to inject malicious HTML/JavaScript. Additionally, the endpoint has no authentication middleware, allowing any registered user to exploit this vulnerability. This vulnerability is fixed in 0.14.3.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-52816?

3 open source packages ship an affected version, including gogs.io/gogs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |

## How do I fix CVE-2026-52816?

Upgrade gogs.io/gogs to 0.14.3 or later.

## Is CVE-2026-52816 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52816 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52816 and fix it if it is affected.

What it is: CVE-2026-52816 is a medium-severity cross-site scripting vulnerability in gogs, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52816 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52816/ (Markdown: https://insights.sbomify.com/CVE-2026-52816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52816
- OSV: https://osv.dev/vulnerability/CVE-2026-52816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52816/
Summaries are generated and may contain mistakes; the official description above is the record.
