{"answers":{"affected":"3 open source packages ship an affected version, including linuxfabrik-lib.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52817 exists.","fix":"Upgrade linuxfabrik-lib to 5.1.0 or later.","what":"CVE-2026-52817 is a high-severity vulnerability in Linuxfabrik monitoring-plugins, published on 18 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-52817 and fix it if it is affected.\n\nWhat it is: CVE-2026-52817 is a high-severity vulnerability in Linuxfabrik monitoring-plugins, published on 18 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52817 exists.\n\nAffected packages and fixed versions:\n- linuxfabrik-lib (PyPI): affected all versions; fixed in 5.1.0\n- linuxfabrik-lib (PyPI): affected all versions; fixed in 5.1.0\n- linuxfabrik-lib (PyPI): affected all versions; fixed in 5.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-52817/ (Markdown: https://insights.sbomify.com/CVE-2026-52817/index.md)","id":"CVE-2026-52817","markdown":"https://insights.sbomify.com/CVE-2026-52817/index.md","name":"CVE-2026-52817","record":{"aliases":["GHSA-8w6w-23mq-h8rg","PYSEC-2026-2595"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Monitoring plugins","requires_auth":"high_privilege","summary":"Attackers with monitoring account access can escalate to root via unrestricted apt-get arguments in Linuxfabrik Monitoring Plugins.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"Linuxfabrik Monitoring Plugins provides monitoring plugins for Icinga, Nagios, and related systems. Prior to version 5.1.0, the shipped assets/sudoers/Debian.sudoers policy allowed the nagios or icinga account to execute /usr/bin/apt-get as root without restricting its arguments. An attacker who already controls that monitoring account can supply the APT::Update::Pre-Invoke option to execute an arbitrary command while apt-get runs with root privileges, resulting in a root shell and complete compromise of the host. The vulnerable rule supports the check-plugins/deb-updates/deb-updates plugin, but it authorized arbitrary apt-get argument sequences rather than only the required apt-get update --quiet 2 command. This issue is fixed in version 5.1.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Linuxfabrik Monitoring Plugins Sudoers: /usr/bin/apt-get arguments allow privilege escalation","id":"CVE-2026-52817","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Kimai: Teamlead authorization bypass in GET /api/timesheets allows reading other users' timesheet records without being teamlead of the target","id":"CVE-2026-52819"},"packages":[{"ecosystem":"PyPI","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"linuxfabrik-lib","purl":null,"source":"GHSA-8w6w-23mq-h8rg"},{"ecosystem":"PyPI","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"linuxfabrik-lib","purl":"pkg:pypi/linuxfabrik-lib","source":"GHSA-8w6w-23mq-h8rg"},{"ecosystem":"PyPI","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"linuxfabrik-lib","purl":"pkg:pypi/linuxfabrik-lib","source":"PYSEC-2026-2595"}],"prev":{"headline":"Gogs: Unauthenticated Jupyter Notebook (ipynb) Sanitizer allows arbitrary data: URIs leading to XSS","id":"CVE-2026-52816"},"products":["monitoring-plugins"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-19","vendors":["Linuxfabrik"]},"summary":"Attackers with monitoring account access can escalate to root via unrestricted apt-get arguments in Linuxfabrik Monitoring Plugins.","url":"https://insights.sbomify.com/CVE-2026-52817/"}