# CVE-2026-52819: Kimai: Teamlead authorization bypass in GET /api/timesheets allows reading other users' timesheet records without being teamlead of the target

> A teamlead can read other users' timesheet records without proper authorization checks, exposing sensitive timing and rate data.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-4m8q-55qv-9pwp

## What is CVE-2026-52819?

CVE-2026-52819 is a medium-severity missing authorization vulnerability in kimai, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kimai is an open-source time tracking application. Prior to 2.57.0, the GET /api/timesheets list endpoint accepts user and users[] target identifiers from a caller with view_other_timesheet but does not apply access_user or verify that a ROLE_TEAMLEAD requester leads a team containing each target user. TimesheetController::cgetAction() adds the resolved users directly to the query while project and customer filtering still permits records on unscoped projects or projects sharing ordinary team membership, allowing a teamlead to retrieve another user's descriptions, timing data, tags, rate, and internalRate even though GET /api/timesheets/{id} would deny access through TimesheetVoter. This issue is fixed in version 2.57.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-52819?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.57.0 |
| `kimai/kimai` | Packagist | All versions | 2.57.0 |

## How do I fix CVE-2026-52819?

Upgrade kimai/kimai to 2.57.0 or later.

## Is CVE-2026-52819 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52819 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52819 and fix it if it is affected.

What it is: CVE-2026-52819 is a medium-severity missing authorization vulnerability in kimai, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52819 exists.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.57.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.57.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52819/ (Markdown: https://insights.sbomify.com/CVE-2026-52819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52819
- OSV: https://osv.dev/vulnerability/CVE-2026-52819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52819/
Summaries are generated and may contain mistakes; the official description above is the record.
