# CVE-2026-52821: Kimai: Improper Authorization Through Activity Creation with Preset Project Allows Creation Under Unauthorized Projects

> Attackers with basic creation rights can create activities or projects under unauthorized parents, corrupting billing and reporting data.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-3q6q-26vg-v97x

## What is CVE-2026-52821?

CVE-2026-52821 is a medium-severity missing authorization vulnerability in kimai, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kimai is an open-source time tracking application. Prior to 2.57.0, GET or POST requests to /en/admin/activity/create/{project} and /en/admin/project/create/{customer} require only the generic create_activity or create_project capability and do not verify edit access to the supplied Project or Customer object. A user who knows a valid project.id or customer identifier can use the preset-parent creation logic in src/Controller/ActivityController.php or src/Controller/ProjectController.php to persist a new child business object under an unauthorized parent, polluting project or customer configuration and influencing later time-entry, rate, reporting, and billing behavior. This issue is fixed in version 2.57.0.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-52821?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.57.0 |
| `kimai/kimai` | Packagist | All versions | 2.57.0 |

## How do I fix CVE-2026-52821?

Upgrade kimai/kimai to 2.57.0 or later.

## Is CVE-2026-52821 being exploited?

There is no known exploitation of CVE-2026-52821 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52821 and fix it if it is affected.

What it is: CVE-2026-52821 is a medium-severity missing authorization vulnerability in kimai, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-52821 in the wild and no public exploit code.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.57.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.57.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52821/ (Markdown: https://insights.sbomify.com/CVE-2026-52821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52821
- OSV: https://osv.dev/vulnerability/CVE-2026-52821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52821/
Summaries are generated and may contain mistakes; the official description above is the record.
