# CVE-2026-52825: Kimai has Improper Authorization in Team Member and Team Activity Assignment APIs Which Allows Expansion of Team Scope Beyond Authorized Visibility

> Team leads can add unauthorized users or activities to teams via API, bypassing visibility restrictions and affecting downstream authorization logic.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-xv4r-4885-gwpg

## What is CVE-2026-52825?

CVE-2026-52825 is a medium-severity missing authorization vulnerability in kimai, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kimai is an open-source time tracking application. Prior to 2.58.0, POST /api/teams/{id}/members/{userId} and POST /api/teams/{id}/activities/{activityId} verify that a teamlead may edit the Team but do not verify access_user for the referenced User or view access for the referenced Activity. A teamlead can add users or activities outside the teamlead's manageable scope to an editable team, bypassing the narrower choices enforced by TeamEditForm and UserRepository::getQueryBuilderForFormType(). The resulting relationships can be trusted by RolePermissionManager::checkTeamAccessActivity() and other team-based authorization, visibility, reporting, and workflow logic. This issue is fixed in version 2.58.0.

Weakness: CWE-862 (Missing Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-52825?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.58.0 |
| `kimai/kimai` | Packagist | All versions | 2.58.0 |

## How do I fix CVE-2026-52825?

Upgrade kimai/kimai to 2.58.0 or later.

## Is CVE-2026-52825 being exploited?

There is no known exploitation of CVE-2026-52825 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52825 and fix it if it is affected.

What it is: CVE-2026-52825 is a medium-severity missing authorization vulnerability in kimai, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-52825 in the wild and no public exploit code.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.58.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.58.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52825/ (Markdown: https://insights.sbomify.com/CVE-2026-52825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52825
- OSV: https://osv.dev/vulnerability/CVE-2026-52825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52825/
Summaries are generated and may contain mistakes; the official description above is the record.
