# CVE-2026-52827: Kimai: Two-factor authentication bypass on the Kimai API

> Attackers with valid passwords can bypass two-factor authentication to access the Kimai REST API without providing the second factor.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-v8hx-4vx8-wc96

## What is CVE-2026-52827?

CVE-2026-52827 is a high-severity authentication bypass vulnerability in kimai, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kimai is an open-source time tracking application. Prior to 2.59.0, the KIMAI_SESSION cookie issued after password verification but before TOTP completion is accepted by every /api route because config/packages/security.yaml protects the API with IS_AUTHENTICATED and App\API\Authentication\ApiRequestMatcher routes an existing session through the main firewall. A Scheb TwoFactorToken satisfies that access rule, and App\Voter\ApiVoter grants API access to its User, allowing an attacker with a valid account password to use authenticated REST API operations without entering the second factor even though web routes remain blocked. This issue is fixed in version 2.59.0.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-52827?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.59.0 |
| `kimai/kimai` | Packagist | All versions | 2.59.0 |

## How do I fix CVE-2026-52827?

Upgrade kimai/kimai to 2.59.0 or later.

## Is CVE-2026-52827 being exploited?

There is no known exploitation of CVE-2026-52827 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52827 and fix it if it is affected.

What it is: CVE-2026-52827 is a high-severity authentication bypass vulnerability in kimai, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-52827 in the wild and no public exploit code.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.59.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.59.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52827/ (Markdown: https://insights.sbomify.com/CVE-2026-52827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52827
- OSV: https://osv.dev/vulnerability/CVE-2026-52827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52827/
Summaries are generated and may contain mistakes; the official description above is the record.
