# CVE-2026-52828: Kimai: ExportTemplate CRUD Missing Authorization Check Allows Unauthorized TEAMLEAD Access

> A teamlead can bypass authorization checks to create or modify global export templates, altering export settings for all users.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-rw46-qg69-vg6h

## What is CVE-2026-52828?

CVE-2026-52828 is a medium-severity missing authorization vulnerability in kimai, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kimai is an open-source time tracking application. Prior to 2.58.0, ExportController::createExportTemplate() and ExportController::editExportTemplate() inherit only the class-level create_export permission, which ROLE_TEAMLEAD receives by default, and omit the create_export_template permission required by the API routes and user interface. A teamlead can directly access the export template creation and editing web routes to create or modify global ExportTemplate records marked available to all users, altering export columns, renderer, format, and output used by other users and administrators. This issue is fixed in version 2.58.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-52828?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.58.0 |
| `kimai/kimai` | Packagist | All versions | 2.58.0 |

## How do I fix CVE-2026-52828?

Upgrade kimai/kimai to 2.58.0 or later.

## Is CVE-2026-52828 being exploited?

There is no known exploitation of CVE-2026-52828 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52828 and fix it if it is affected.

What it is: CVE-2026-52828 is a medium-severity missing authorization vulnerability in kimai, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-52828 in the wild and no public exploit code.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.58.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.58.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52828/ (Markdown: https://insights.sbomify.com/CVE-2026-52828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52828
- OSV: https://osv.dev/vulnerability/CVE-2026-52828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52828/
Summaries are generated and may contain mistakes; the official description above is the record.
