# CVE-2026-52829: ZEBRA: IPv4-Mapped Mempool Misbehavior Update Aborts Zebra Address Book

> An unauthenticated peer can crash a synced Zebra node by triggering an assertion failure during mempool misbehavior updates.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-63wg-wjjj-7cp8

## What is CVE-2026-52829?

CVE-2026-52829 is a high-severity denial of service vulnerability in ZcashFoundation zebra, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ZEBRA is a Zcash node written entirely in Rust. Prior to 4.5.0, an unauthenticated IPv4 peer can deterministically terminate a synced Zebra node using the default Linux dual-stack listener configuration. The handshake path canonicalized an IPv4-mapped IPv6 PeerSocketAddr such as ::ffff:127.0.0.1 to plain IPv4 before storing it through MetaAddr::new_connected, but the mempool misbehavior path forwarded the raw transient address to MetaAddrChange::UpdateMisbehavior. In zebra-network/src/meta_addr.rs, apply_to_meta_addr then compared the canonical address-book entry with the raw update address and reached its unexpected address mismatch assertion. After the misbehavior batch flush, panic equals abort terminated zebrad; the peer only needed to complete a P2P handshake and advertise an invalid mempool transaction. This issue is fixed in version 4.5.0.

Weakness: CWE-843 (Access of Resource Using Incompatible Type), CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-52829?

4 open source packages ship an affected version, including zebra-network and zebrad.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zebra-network` | crates.io | All versions | 7.0.0 |
| `zebra-network` | crates.io | All versions | 7.0.0 |
| `zebrad` | crates.io | All versions | 4.5.0 |
| `zebrad` | crates.io | All versions | 4.5.0 |

## How do I fix CVE-2026-52829?

Upgrade zebra-network to 7.0.0 or later.

## Is CVE-2026-52829 being exploited?

There is no known exploitation of CVE-2026-52829 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52829 and fix it if it is affected.

What it is: CVE-2026-52829 is a high-severity denial of service vulnerability in ZcashFoundation zebra, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-52829 in the wild and no public exploit code.

Affected packages and fixed versions:
- zebra-network (crates.io): affected all versions; fixed in 7.0.0
- zebra-network (crates.io): affected all versions; fixed in 7.0.0
- zebrad (crates.io): affected all versions; fixed in 4.5.0
- zebrad (crates.io): affected all versions; fixed in 4.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52829/ (Markdown: https://insights.sbomify.com/CVE-2026-52829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52829
- OSV: https://osv.dev/vulnerability/CVE-2026-52829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52829/
Summaries are generated and may contain mistakes; the official description above is the record.
