# CVE-2026-52830: fast-mcp-telegram: Bearer token path traversal bypasses reserved Telegram session protection

> Remote attackers can bypass reserved session protections via path traversal in Bearer token validation, accessing default account sessions.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-rxw2-pc8j-vxwm, PYSEC-2026-2473

## What is CVE-2026-52830?

CVE-2026-52830 is a critical path traversal vulnerability in leshchenko1979 fast-mcp-telegram, published on 2 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-mcp-telegram is a Telegram MCP Server. Prior to 0.19.1, fast-mcp-telegram validates HTTP Bearer tokens by joining the raw token string into a session-file path. The verifier rejects the exact reserved token telegram, but it does not reject path separators or normalize the path before checking whether the session file exists. A remote HTTP client can therefore authenticate as the default legacy session with a token such as ../fast-mcp-telegram/telegram when the documented default session file ~/.config/fast-mcp-telegram/telegram.session exists. This bypasses the reserved session name control that is intended to prevent HTTP multi-user sessions from colliding with the default stdio or legacy account. With account-prefixed MCP tools enabled, the attacker still sees and calls the prefixed tools for the default account, so the prefix middleware does not stop the session selection bypass. This vulnerability is fixed in 0.19.1.

Weakness: CWE-287 (Improper Authentication), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-52830?

3 open source packages ship an affected version, including fast-mcp-telegram.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-mcp-telegram` | PyPI | All versions | 0.19.1 |
| `fast-mcp-telegram` | PyPI | All versions | 0.19.1 |
| `fast-mcp-telegram` | PyPI | All versions | 0.19.1 |

## How do I fix CVE-2026-52830?

Upgrade fast-mcp-telegram to 0.19.1 or later.

## Is CVE-2026-52830 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52830 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52830 and fix it if it is affected.

What it is: CVE-2026-52830 is a critical path traversal vulnerability in leshchenko1979 fast-mcp-telegram, published on 2 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52830 exists.

Affected packages and fixed versions:
- fast-mcp-telegram (PyPI): affected all versions; fixed in 0.19.1
- fast-mcp-telegram (PyPI): affected all versions; fixed in 0.19.1
- fast-mcp-telegram (PyPI): affected all versions; fixed in 0.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52830/ (Markdown: https://insights.sbomify.com/CVE-2026-52830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52830
- OSV: https://osv.dev/vulnerability/CVE-2026-52830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52830/
Summaries are generated and may contain mistakes; the official description above is the record.
